HPE NC523SFP with VMware ESXi 6.5 Fix

After VMware basically gave up up on this ticket I was able to figure out that if you want to get the NC523SFP 10GBe adapter to work in ESXi 6.5+ you need to manually add this VIB driver, not the one that VMware has listed.

https://www.vmware.com/resources/compatibility/detail.php?deviceCategory=io&productid=19404

I have confirmed that this updated driver "qlcnic version 6.1.191" works with ESXi 6.5 on an DL360 Gen8 with 1 x NC523SFP running firmware version 4.20.1 (4.20.20 is not available anymore from HPE as far as I know) This is the fix for the issue below (but I'm not going to post on that horrid website)

This fix should apply to any system running the NC523SFP Network Adapter.

https://www.experts-exchange.com/questions/29018082/VMWare-ESXi-6-5-HP-NC523SFP-10GbE-issues.html

Hopefully this post will help someone save a few hours of troubleshooting.

This article was updated on July 3, 2018

Comments